What’s Vulnerable › Vulnerabilities
CVE-2019-10663
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-30 · updated 2026-06-17
- Weakness: CWE-89
Description
Grandstream UCM6204 before 1.0.19.20 devices allow remote authenticated users to conduct SQL injection attacks via the sord parameter in a listCodeblueGroup API call to the /cgi? URI.
Affected products
- Grandstream Ucm6204 Firmware: before 1.0.19.20 — fixed in 1.0.19.20
How to fix
Upgrade to a fixed version: Grandstream Ucm6204 Firmware 1.0.19.20. Check the vendor advisory for mitigations.
References
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1
Get alerted when CVE-2019-10663 or the next vulnerability affects your stack