What’s Vulnerable › Vulnerabilities
CVE-2019-10691
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-24 · updated 2026-06-17
Description
The JSON encoder in Dovecot before 2.3.5.2 allows attackers to repeatedly crash the authentication service by attempting to authenticate with an invalid UTF-8 sequence as the username.
Affected products
- dovecot: before 2.3.5.2 — fixed in 2.3.5.2
- openSUSE Leap: 15.0
How to fix
Upgrade to a fixed version: dovecot 2.3.5.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00000.html
- http://www.openwall.com/lists/oss-security/2019/04/18/3
- https://dovecot.org/list/dovecot-news/2019-April/000406.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QHFZ5OWRIZGIWZJ5PTNVWWZNLLNH4XYS/
- https://security.gentoo.org/glsa/201908-29
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00000.html
- http://www.openwall.com/lists/oss-security/2019/04/18/3
- https://dovecot.org/list/dovecot-news/2019-April/000406.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QHFZ5OWRIZGIWZJ5PTNVWWZNLLNH4XYS/
- https://security.gentoo.org/glsa/201908-29
Get alerted when CVE-2019-10691 or the next vulnerability affects your stack