What’s Vulnerable › Vulnerabilities
CVE-2019-10694
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-12 · updated 2026-06-17
- Weakness: CWE-798
Description
The express install, which is the suggested way to install Puppet Enterprise, gives the user a URL at the end of the install to set the admin password. If they do not use that URL, there is an overlooked default password for the admin user. This was resolved in Puppet Enterprise 2019.0.3 and 2018.1.9.
Affected products
- Puppet Enterprise: from 2018.1.0 before 2018.1.9; from 2019.0 before 2019.0.3 — fixed in 2018.1.9, 2019.0.3
How to fix
Upgrade to a fixed version: Puppet Enterprise 2018.1.9, 2019.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-10694 or the next vulnerability affects your stack