What’s Vulnerable › Vulnerabilities
CVE-2019-10714
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-02 · updated 2026-06-17
- Weakness: CWE-125
Description
LocaleLowercase in MagickCore/locale.c in ImageMagick before 7.0.8-32 allows out-of-bounds access, leading to a SIGSEGV.
Affected products
- ImageMagick: before 6.9.10-32; from 7.0.0-0 before 7.0.8-32 — fixed in 6.9.10-32, 7.0.8-32
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-32, 7.0.8-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/07eebcd72f45c8fd7563d3f9ec5d2bed48f65f36
- https://github.com/ImageMagick/ImageMagick/commit/58d9c46929ca0828edde34d263700c3a5fe8dc3c
- https://github.com/ImageMagick/ImageMagick/commit/edc7d3035883ddca8413e4fe7689aa2e579ef04a
- https://github.com/ImageMagick/ImageMagick/issues/1495
- https://github.com/ImageMagick/ImageMagick/commit/07eebcd72f45c8fd7563d3f9ec5d2bed48f65f36
- https://github.com/ImageMagick/ImageMagick/commit/58d9c46929ca0828edde34d263700c3a5fe8dc3c
- https://github.com/ImageMagick/ImageMagick/commit/edc7d3035883ddca8413e4fe7689aa2e579ef04a
- https://github.com/ImageMagick/ImageMagick/issues/1495
Get alerted when CVE-2019-10714 or the next vulnerability affects your stack