What’s Vulnerable › Vulnerabilities

CVE-2019-10748

Description

Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.

Affected products

How to fix

Upgrade to a fixed version: sequelize 3.35.1, 4.44.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-10748 or the next vulnerability affects your stack