What’s Vulnerable › Vulnerabilities
CVE-2019-10749
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-29 · updated 2026-06-17
- Weakness: CWE-89
Description
sequelize before version 3.35.1 allows attackers to perform a SQL Injection due to the JSON path keys not being properly sanitized in the Postgres dialect.
Affected products
- sequelize: before 3.35.1 — fixed in 3.35.1
How to fix
Upgrade to a fixed version: sequelize 3.35.1. Check the vendor advisory for mitigations.
References
- https://github.com/sequelize/sequelize/commit/ee4017379db0059566ecb5424274ad4e2d66bc68
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-450222
- https://github.com/sequelize/sequelize/commit/ee4017379db0059566ecb5424274ad4e2d66bc68
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-450222
Get alerted when CVE-2019-10749 or the next vulnerability affects your stack