What’s Vulnerable › Vulnerabilities
CVE-2019-10752
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-17 · updated 2026-06-17
- Weakness: CWE-89
Description
Sequelize, all versions prior to version 4.44.3 and 5.15.1, is vulnerable to SQL Injection due to sequelize.json() helper function not escaping values properly when formatting sub paths for JSON queries for MySQL, MariaDB and SQLite.
Affected products
- sequelize: from 4.0.0 before 4.44.3; from 5.0.0 before 5.15.1 — fixed in 4.44.3, 5.15.1
How to fix
Upgrade to a fixed version: sequelize 4.44.3, 5.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/sequelize/sequelize/commit/9bd0bc1%2C
- https://github.com/sequelize/sequelize/commit/9bd0bc111b6f502223edf7e902680f7cc2ed541e
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-459751%2C
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-459751
- https://github.com/sequelize/sequelize/commit/9bd0bc1%2C
- https://github.com/sequelize/sequelize/commit/9bd0bc111b6f502223edf7e902680f7cc2ed541e
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-459751%2C
Get alerted when CVE-2019-10752 or the next vulnerability affects your stack