What’s Vulnerable › Vulnerabilities
CVE-2019-10756
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-08 · updated 2026-06-17
- Weakness: CWE-79
Description
It is possible to inject JavaScript within node-red-dashboard versions prior to version 2.17.0 due to the ui_notification node accepting raw HTML by default.
Affected products
- node-red-dashboard: before 2.17.0 — fixed in 2.17.0
How to fix
Upgrade to a fixed version: node-red-dashboard 2.17.0. Check the vendor advisory for mitigations.
References
- https://snyk.io/vuln/SNYK-JS-NODEREDDASHBOARD-471939
- https://snyk.io/vuln/SNYK-JS-NODEREDDASHBOARD-471939
Get alerted when CVE-2019-10756 or the next vulnerability affects your stack