What’s Vulnerable › Vulnerabilities
CVE-2019-10757
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-08 · updated 2026-06-17
- Weakness: CWE-89
Description
knex.js versions before 0.19.5 are vulnerable to SQL Injection attack. Identifiers are escaped incorrectly as part of the MSSQL dialect, allowing attackers to craft a malicious query to the host DB.
Affected products
- knex.js: before 0.19.5 — fixed in 0.19.5
How to fix
Upgrade to a fixed version: knex.js 0.19.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-10757 or the next vulnerability affects your stack