What’s Vulnerable › Vulnerabilities
CVE-2019-10758: MongoDB mongo-express Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-12-10
- EPSS: 84.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-24 · updated 2026-06-17
- Weakness: CWE-94
Description
mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method. A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment.
Affected products
- mongo-express: before 0.54.0 — fixed in 0.54.0
How to fix
Upgrade to a fixed version: mongo-express 0.54.0. Check the vendor advisory for mitigations.
References
- https://snyk.io/vuln/SNYK-JS-MONGOEXPRESS-473215
- https://snyk.io/vuln/SNYK-JS-MONGOEXPRESS-473215
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-10758
Get alerted when CVE-2019-10758 or the next vulnerability affects your stack