What’s Vulnerable › Vulnerabilities
CVE-2019-10760
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-15 · updated 2026-06-17
Description
safer-eval before 1.3.2 are vulnerable to Arbitrary Code Execution. A payload using constructor properties can escape the sandbox and execute arbitrary code.
Affected products
- Snyk safer-eval: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: Snyk safer-eval 1.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-10760 or the next vulnerability affects your stack