What’s Vulnerable › Vulnerabilities
CVE-2019-10763
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-17
- Weakness: CWE-89
Description
pimcore/pimcore before 6.3.0 is vulnerable to SQL Injection. An attacker with limited privileges (classes permission) can achieve a SQL injection that can lead in data leakage. The vulnerability can be exploited via 'id', 'storeId', 'pageSize' and 'tables' parameters, using a payload for trigger a time based or error based sql injection.
Affected products
- pimcore/pimcore: before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: pimcore/pimcore 6.3.0. Check the vendor advisory for mitigations.
References
- https://blog.certimetergroup.com/it/articolo/security/sql_injection_in_pimcore_6.2.3
- https://snyk.io/vuln/SNYK-PHP-PIMCOREPIMCORE-480391
- https://blog.certimetergroup.com/it/articolo/security/sql_injection_in_pimcore_6.2.3
- https://snyk.io/vuln/SNYK-PHP-PIMCOREPIMCORE-480391
Get alerted when CVE-2019-10763 or the next vulnerability affects your stack