What’s Vulnerable › Vulnerabilities
CVE-2019-10766
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-19 · updated 2026-06-17
- Weakness: CWE-89
Description
Pixie versions 1.0.x before 1.0.3, and 2.0.x before 2.0.2 allow SQL Injection in the limit() function due to improper sanitization.
Affected products
- Pixie Query Builder: from 1.0.0 before 1.0.3; from 2.0.0 before 2.0.2 — fixed in 1.0.3, 2.0.2
How to fix
Upgrade to a fixed version: Pixie Query Builder 1.0.3, 2.0.2. Check the vendor advisory for mitigations.
References
- https://snyk.io/vuln/SNYK-PHP-USMANHALALITPIXIE-534879
- https://snyk.io/vuln/SNYK-PHP-USMANHALALITPIXIE-534879
Get alerted when CVE-2019-10766 or the next vulnerability affects your stack