What’s Vulnerable › Vulnerabilities
CVE-2019-10767
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-21 · updated 2026-06-17
- Weakness: CWE-22
Description
An attacker can include file contents from outside the `/adapter/xxx/` directory, where `xxx` is the name of an existent adapter like "admin". It is exploited using the administrative web panel with a request for an adapter file. **Note:** The attacker has to be logged in if the authentication is enabled (by default isn't enabled).
Affected products
- iobroker.js-controller: before 2.0.25 — fixed in 2.0.25
How to fix
Upgrade to a fixed version: iobroker.js-controller 2.0.25. Check the vendor advisory for mitigations.
References
- https://github.com/ioBroker/ioBroker.js-controller/commit/f6e292c6750a491a5000d0f851b2fede4f9e2fda
- https://snyk.io/vuln/SNYK-JS-IOBROKERJSCONTROLLER-534881
- https://github.com/ioBroker/ioBroker.js-controller/commit/f6e292c6750a491a5000d0f851b2fede4f9e2fda
- https://snyk.io/vuln/SNYK-JS-IOBROKERJSCONTROLLER-534881
Get alerted when CVE-2019-10767 or the next vulnerability affects your stack