What’s Vulnerable › Vulnerabilities
CVE-2019-10770
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
All versions of io.ratpack:ratpack-core from 0.9.10 inclusive and before 1.7.6 are vulnerable to Cross-site Scripting (XSS). This affects the development mode error handler when an exception message contains untrusted data. Note the production mode error handler is not vulnerable - so for this to be utilized in production it would require users to not disable development mode.
Affected products
- io.ratpack:ratpack-core: from 0.9.10 before 1.7.6 — fixed in 1.7.6
How to fix
Upgrade to a fixed version: io.ratpack:ratpack-core 1.7.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-10770 or the next vulnerability affects your stack