What’s Vulnerable › Vulnerabilities
CVE-2019-10774
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-30 · updated 2026-06-17
- Weakness: CWE-78
Description
php-shellcommand versions before 1.6.1 have a command injection vulnerability. Successful exploitation could lead to arbitrary code execution.
Affected products
- php-shellcommand: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: php-shellcommand 1.6.1. Check the vendor advisory for mitigations.
References
- https://snyk.io/vuln/SNYK-PHP-MIKEHAERTLPHPSHELLCOMMAND-538426
- https://snyk.io/vuln/SNYK-PHP-MIKEHAERTLPHPSHELLCOMMAND-538426
Get alerted when CVE-2019-10774 or the next vulnerability affects your stack