What’s Vulnerable › Vulnerabilities
CVE-2019-10775: Denial of Service in ecstatic
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-02 · updated 2026-06-17
- Weakness: CWE-400
Description
ecstatic have a denial of service vulnerability. Successful exploitation could lead to crash of an application.
Affected products
- HackerOne ecstatic node module: all versions
- Npm Ecstatic: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: Npm Ecstatic 4.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-10775 or the next vulnerability affects your stack