What’s Vulnerable › Vulnerabilities
CVE-2019-10776
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-07 · updated 2026-06-17
- Weakness: CWE-78
Description
In "index.js" file line 240, the run command executes the git command with a user controlled variable called remoteUrl. This affects git-diff-apply all versions prior to 0.22.2.
Affected products
- git-diff-apply: before 0.22.2 — fixed in 0.22.2
How to fix
Upgrade to a fixed version: git-diff-apply 0.22.2. Check the vendor advisory for mitigations.
References
- https://github.com/kellyselden/git-diff-apply/commit/106d61d3ae723b4257c2a13e67b95eb40a27e0b5
- https://snyk.io/vuln/SNYK-JS-GITDIFFAPPLY-540774%2C
- https://snyk.io/vuln/SNYK-JS-GITDIFFAPPLY-540774
- https://github.com/kellyselden/git-diff-apply/commit/106d61d3ae723b4257c2a13e67b95eb40a27e0b5
- https://snyk.io/vuln/SNYK-JS-GITDIFFAPPLY-540774%2C
Get alerted when CVE-2019-10776 or the next vulnerability affects your stack