What’s Vulnerable › Vulnerabilities
CVE-2019-10778
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-08 · updated 2026-06-17
- Weakness: CWE-78
Description
devcert-sanscache before 0.4.7 allows remote attackers to execute arbitrary code or cause a Command Injection via the exec function. The variable `commonName` controlled by user input is used as part of the `exec` function without any sanitization.
Affected products
- devcert-sanscache: before 0.4.7 — fixed in 0.4.7
How to fix
Upgrade to a fixed version: devcert-sanscache 0.4.7. Check the vendor advisory for mitigations.
References
- https://snyk.io/vuln/SNYK-JS-DEVCERTSANSCACHE-540926
- https://snyk.io/vuln/SNYK-JS-DEVCERTSANSCACHE-540926
Get alerted when CVE-2019-10778 or the next vulnerability affects your stack