What’s Vulnerable › Vulnerabilities

CVE-2019-10779

Description

All versions of stroom:stroom-app before 5.5.12 and all versions of the 6.0.0 branch before 6.0.25 are affected by Cross-site Scripting. An attacker website is able to load the Stroom UI into a hidden iframe. Using that iframe, the attacker site can issue commands to the Stroom UI via an XSS vulnerability to take full control of the Stroom UI on behalf of the logged-in user.

Affected products

How to fix

Upgrade to a fixed version: stroom:stroom-app 5.5.12, 6.0.25. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-10779 or the next vulnerability affects your stack