What’s Vulnerable › Vulnerabilities
CVE-2019-10780
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-22 · updated 2026-06-17
- Weakness: CWE-78
Description
BibTeX-ruby before 5.1.0 allows shell command injection due to unsanitized user input being passed directly to the built-in Ruby Kernel.open method through BibTeX.open.
Affected products
- BibTeX-ruby: before 5.1.0 — fixed in 5.1.0
How to fix
Upgrade to a fixed version: BibTeX-ruby 5.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-10780 or the next vulnerability affects your stack