What’s Vulnerable › Vulnerabilities
CVE-2019-10781
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-22 · updated 2026-06-17
- Weakness: CWE-668
Description
In schema-inspector before 1.6.9, a maliciously crafted JavaScript object can bypass the `sanitize()` and the `validate()` function used within schema-inspector.
Affected products
- Snyk schema-inspector: before 1.6.9 — fixed in 1.6.9
How to fix
Upgrade to a fixed version: Snyk schema-inspector 1.6.9. Check the vendor advisory for mitigations.
References
- https://github.com/Atinux/schema-inspector/commit/345a7b2eed11bb6128421150d65f4f83fdbb737d
- https://snyk.io/vuln/SNYK-JS-SCHEMAINSPECTOR-536970
- https://github.com/Atinux/schema-inspector/commit/345a7b2eed11bb6128421150d65f4f83fdbb737d
- https://snyk.io/vuln/SNYK-JS-SCHEMAINSPECTOR-536970
Get alerted when CVE-2019-10781 or the next vulnerability affects your stack