What’s Vulnerable › Vulnerabilities
CVE-2019-10782
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-30 · updated 2026-06-17
- Weakness: CWE-611
Description
All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.
Affected products
- com.puppycrawl.tools:checkstyle: before 8.29 — fixed in 8.29
How to fix
Upgrade to a fixed version: com.puppycrawl.tools:checkstyle 8.29. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/r8aaf4ee16bbaf6204731d4770d96ebb34b258cd79b491f9cdd7f2540%40%3Ccommits.nifi.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2020/02/msg00008.html
- https://snyk.io/vuln/SNYK-JAVA-COMPUPPYCRAWLTOOLS-543266
- https://lists.apache.org/thread.html/r8aaf4ee16bbaf6204731d4770d96ebb34b258cd79b491f9cdd7f2540%40%3Ccommits.nifi.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2020/02/msg00008.html
- https://snyk.io/vuln/SNYK-JAVA-COMPUPPYCRAWLTOOLS-543266
Get alerted when CVE-2019-10782 or the next vulnerability affects your stack