What’s Vulnerable › Vulnerabilities

CVE-2019-10785

Description

dojox is vulnerable to Cross-site Scripting in all versions before version 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7 and 1.11.9. This is due to dojox.xmpp.util.xmlEncode only encoding the first occurrence of each character, not all of them.

Affected products

How to fix

Upgrade to a fixed version: dojox 1.11.9, 1.12.7, 1.13.6, 1.14.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-10785 or the next vulnerability affects your stack