What’s Vulnerable › Vulnerabilities
CVE-2019-10807
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-11 · updated 2026-06-17
- Weakness: CWE-78
Description
Blamer versions prior to 1.0.1 allows execution of arbitrary commands. It is possible to inject arbitrary commands as part of the arguments provided to blamer.
Affected products
- blamer: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: blamer 1.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/kucherenko/blamer/commit/5fada8c9b6986ecd28942b724fa682e77ce1e11c%2C
- https://snyk.io/vuln/SNYK-JS-BLAMER-559541
- https://github.com/kucherenko/blamer/commit/5fada8c9b6986ecd28942b724fa682e77ce1e11c%2C
- https://snyk.io/vuln/SNYK-JS-BLAMER-559541
Get alerted when CVE-2019-10807 or the next vulnerability affects your stack