What’s Vulnerable › Vulnerabilities
CVE-2019-10808
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-11 · updated 2026-06-17
- Weakness: CWE-1321
Description
utilitify prior to 1.0.3 allows modification of object properties. The merge method could be tricked into adding or modifying properties of the Object.prototype.
Affected products
- utilitify: before 1.0.3 — fixed in 1.0.3
How to fix
Upgrade to a fixed version: utilitify 1.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/xcritical-software/utilitify/commit/88d6e27009823338bf319ffb768fe6b08e8ad2d1%2C
- https://snyk.io/vuln/SNYK-JS-UTILITIFY-559497
- https://github.com/xcritical-software/utilitify/commit/88d6e27009823338bf319ffb768fe6b08e8ad2d1%2C
- https://snyk.io/vuln/SNYK-JS-UTILITIFY-559497
Get alerted when CVE-2019-10808 or the next vulnerability affects your stack