What’s Vulnerable › Vulnerabilities
CVE-2019-10863
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-04 · updated 2026-06-17
- Weakness: CWE-94
Description
A command injection vulnerability exists in TeemIp versions before 2.4.0. The new_config parameter of exec.php allows one to create a new PHP file with the exception of config information. The malicious PHP code sent is executed instantaneously and is not saved on the server.
Affected products
- Combodo Teemip: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Combodo Teemip 2.4.0. Check the vendor advisory for mitigations.
References
- https://pentest.com.tr/exploits/TeemIp-IPAM-2-4-0-new-config-Command-Injection-Metasploit.html
- https://www.exploit-db.com/exploits/46641
- https://www.exploit-db.com/exploits/46641/
- https://pentest.com.tr/exploits/TeemIp-IPAM-2-4-0-new-config-Command-Injection-Metasploit.html
- https://www.exploit-db.com/exploits/46641
- https://www.exploit-db.com/exploits/46641/
Get alerted when CVE-2019-10863 or the next vulnerability affects your stack