What’s Vulnerable › Vulnerabilities
CVE-2019-10882: Netskope client buffer overflow vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-26 · updated 2026-06-17
- Weakness: CWE-120
Description
The Netskope client service, v57 before 57.2.0.219 and v60 before 60.2.0.214, running with NT\SYSTEM privilege, accepts network connections from localhost. The connection handling function in this service suffers from a stack based buffer overflow in "doHandshakefromServer" function. Local users can use this vulnerability to trigger a crash of the service and potentially cause additional impact on the system.
Affected products
- Netskope Client: from 57 before 57.2.0.219; from 60 before 60.2.0.214 — fixed in 57.2.0.219, 60.2.0.214
How to fix
Upgrade to a fixed version: Netskope Client 57.2.0.219, 60.2.0.214. Check the vendor advisory for mitigations.
References
- https://airbus-seclab.github.io/advisories/netskope.html
- https://support.netskope.com/hc/article_attachments/360033003553/Sprint_62_Release_Notes.pdf
- https://support.netskope.com/hc/en-us/articles/360014589894-Netskope-Client
- https://airbus-seclab.github.io/advisories/netskope.html
- https://support.netskope.com/hc/article_attachments/360033003553/Sprint_62_Release_Notes.pdf
- https://support.netskope.com/hc/en-us/articles/360014589894-Netskope-Client
Get alerted when CVE-2019-10882 or the next vulnerability affects your stack