What’s Vulnerable › Vulnerabilities
CVE-2019-10905
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Parsedown before 1.7.2, when safe mode is used and HTML markup is disabled, might allow attackers to execute arbitrary JavaScript code if a script (already running on the affected page) executes the contents of any element with a specific class. This occurs because spaces are permitted in code block infostrings, which interferes with the intended behavior of a single class name beginning with the language- substring.
Affected products
- Parsedown: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: Parsedown 1.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/erusev/parsedown/issues/699
- https://github.com/erusev/parsedown/releases/tag/1.7.2
- https://github.com/erusev/parsedown/issues/699
- https://github.com/erusev/parsedown/releases/tag/1.7.2
Get alerted when CVE-2019-10905 or the next vulnerability affects your stack