What’s Vulnerable › Vulnerabilities

CVE-2019-10910

Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, when service ids allow user input, this could allow for SQL Injection and remote code execution. This is related to symfony/dependency-injection.

Affected products

How to fix

Upgrade to a fixed version: Drupal 8.5.15, 8.6.15; symfony 2.7.51, 2.8.50, 3.4.26, 4.1.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-10910 or the next vulnerability affects your stack