What’s Vulnerable › Vulnerabilities

CVE-2019-10912

Description

In Symfony before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, it is possible to cache objects that may contain bad user input. On serialization or unserialization, this could result in the deletion of files that the current user has access to. This is related to symfony/cache and symfony/phpunit-bridge.

Affected products

How to fix

Upgrade to a fixed version: symfony 2.8.50, 3.4.26, 4.1.12, 4.2.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-10912 or the next vulnerability affects your stack