What’s Vulnerable › Vulnerabilities

CVE-2019-10913

Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.

Affected products

How to fix

Upgrade to a fixed version: symfony 2.7.51, 2.8.50, 3.4.26, 4.1.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-10913 or the next vulnerability affects your stack