What’s Vulnerable › Vulnerabilities
CVE-2019-10940
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-16 · updated 2026-06-17
- Weakness: CWE-266
Description
A vulnerability has been identified in SINEMA Server (All versions < V14.0 SP2 Update 1). Incorrect session validation could allow an attacker with a valid session, with low privileges, to perform firmware updates and other administrative operations on connected devices. The security vulnerability could be exploited by an attacker with network access to the affected system. An attacker must have access to a low privileged account in order to exploit the vulnerability. An attacker could use the vulnerability to compromise confidentiality, integrity, and availability of the affected system and underlying components. At the time of advisory publication no public exploitation of this security vulnerability was known.
Affected products
- Siemens SINEMA Server V14: before 14.0; 14.0, 14.0-sp1, 14.0-sp2 — fixed in 14.0
How to fix
Upgrade to a fixed version: Siemens SINEMA Server V14 14.0. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-880233.pdf
- https://www.us-cert.gov/ics/advisories/icsa-20-014-02
- https://cert-portal.siemens.com/productcert/pdf/ssa-880233.pdf
- https://www.us-cert.gov/ics/advisories/icsa-20-014-02
Get alerted when CVE-2019-10940 or the next vulnerability affects your stack