What’s Vulnerable › Vulnerabilities
CVE-2019-10970
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-11 · updated 2026-06-17
- Weakness: CWE-284
Description
In Rockwell Automation PanelView 5510 (all versions manufactured before March 13, 2019 that have never been updated to v4.003, v5.002, or later), a remote, unauthenticated threat actor with access to an affected PanelView 5510 Graphic Display, upon successful exploit, may boot-up the terminal and gain root-level access to the device’s file system.
Affected products
- Rockwell Automation PanelView 5510: before 4.003; from 5.000 before 5.002 — fixed in 4.003, 5.002
How to fix
Upgrade to a fixed version: Rockwell Automation PanelView 5510 4.003, 5.002. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/109105
- https://www.us-cert.gov/ics/advisories/icsa-19-190-02
- http://www.securityfocus.com/bid/109105
- https://www.us-cert.gov/ics/advisories/icsa-19-190-02
Get alerted when CVE-2019-10970 or the next vulnerability affects your stack