What’s Vulnerable › Vulnerabilities
CVE-2019-11028
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-09 · updated 2026-06-17
- Weakness: CWE-434
Description
GAT-Ship Web Module before 1.40 suffers from a vulnerability allowing authenticated attackers to upload any file type to the server via the "Documents" area. This vulnerability is related to "uploadDocFile.aspx".
Affected products
- Gatship Web Module: before 1.40 — fixed in 1.40
How to fix
Upgrade to a fixed version: Gatship Web Module 1.40. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/152643/GAT-Ship-Web-Module-Unrestricted-File-Upload.html
- http://seclists.org/fulldisclosure/2019/Apr/33
- https://seclists.org/fulldisclosure/2019/Apr/14
- https://vuldb.com/?id.133141
- http://packetstormsecurity.com/files/152643/GAT-Ship-Web-Module-Unrestricted-File-Upload.html
- http://seclists.org/fulldisclosure/2019/Apr/33
- https://seclists.org/fulldisclosure/2019/Apr/14
- https://vuldb.com/?id.133141
Get alerted when CVE-2019-11028 or the next vulnerability affects your stack