What’s Vulnerable › Vulnerabilities

CVE-2019-11035: Heap over-read in PHP EXIF extension

Description

When processing certain files, PHP EXIF extension in versions 7.1.x below 7.1.28, 7.2.x below 7.2.17 and 7.3.x below 7.3.4 can be caused to read past allocated buffer in exif_iif_add_value function. This may lead to information disclosure or crash.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.1.28, 7.2.17, 7.3.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-11035 or the next vulnerability affects your stack