What’s Vulnerable › Vulnerabilities
CVE-2019-11038: Uninitialized read in gdImageCreateFromXbm
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-19 · updated 2026-06-17
- Weakness: CWE-457
Description
When using the gdImageCreateFromXbm() function in the GD Graphics Library (aka LibGD) 2.2.5, as used in the PHP GD extension in PHP versions 7.1.x below 7.1.30, 7.2.x below 7.2.19 and 7.3.x below 7.3.6, it is possible to supply data that will cause the function to use the value of uninitialized variable. This may lead to disclosing contents of the stack that has been left there by previous code.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.10
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 29, 30, 32
- Libgd: 2.2.5
- openSUSE Leap: 15.1
- PHP: from 7.1.0 before 7.1.30; from 7.2.0 before 7.2.19; from 7.3.0 before 7.3.6 — fixed in 7.1.30, 7.2.19, 7.3.6
- Red Hat Enterprise Linux: 7.0, 8.0
- RedHat Software Collections: 1.0
- SUSE Linux Enterprise Debuginfo: 11-sp4
- SUSE Linux Enterprise Server 15 SP1: 12-sp4
- SUSE Linux Enterprise Server: 12-sp4, 12-sp5
- SUSE Linux Enterprise Software Development Kit: 12-sp4, 12-sp5
- SUSE Linux Enterprise Workstation Extension: 12-sp4, 12-sp5
How to fix
Upgrade to a fixed version: PHP 7.1.30, 7.2.19, 7.3.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00020.html
- https://access.redhat.com/errata/RHSA-2019:2519
- https://access.redhat.com/errata/RHSA-2019:3299
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929821
- https://bugs.php.net/bug.php?id=77973
- https://bugzilla.redhat.com/show_bug.cgi?id=1724149
- https://bugzilla.redhat.com/show_bug.cgi?id=1724432
- https://bugzilla.suse.com/show_bug.cgi?id=1140118
- https://bugzilla.suse.com/show_bug.cgi?id=1140120
- https://github.com/libgd/libgd/issues/501
- https://lists.debian.org/debian-lts-announce/2019/06/msg00003.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3CZ2QADQTKRHTGB2AHD7J4QQNDLBEMM6/
Get alerted when CVE-2019-11038 or the next vulnerability affects your stack