What’s Vulnerable › Vulnerabilities

CVE-2019-11043: PHP FastCGI Process Manager (FPM) Buffer Overflow Vulnerability

Description

In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it is possible to cause FPM module to write past allocated buffers into the space reserved for FCGI protocol data, thus opening the possibility of remote code execution.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.1.33, 7.2.24, 7.3.11; Tenable.sc 5.19.0. Check the vendor advisory for mitigations.

In the news

References

Get alerted when CVE-2019-11043 or the next vulnerability affects your stack