What’s Vulnerable › Vulnerabilities
CVE-2019-11069
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-10 · updated 2026-06-17
- Weakness: CWE-20
Description
Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.
Affected products
- sequelize: from 5.0.0 before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: sequelize 5.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/sequelize/sequelize/blob/98cb17c17f73e2aa1792aa5a1d31216ba984b456/lib/dialects/postgres/connection-manager.js#L158-L160
- https://github.com/sequelize/sequelize/commit/850c7fd04669e0fef9238b6dc4f8d6ee93ed71e9
- https://github.com/sequelize/sequelize/pull/10746/files
- https://github.com/sequelize/sequelize/releases/tag/v5.3.0
- https://github.com/sequelize/sequelize/blob/98cb17c17f73e2aa1792aa5a1d31216ba984b456/lib/dialects/postgres/connection-manager.js#L158-L160
- https://github.com/sequelize/sequelize/commit/850c7fd04669e0fef9238b6dc4f8d6ee93ed71e9
- https://github.com/sequelize/sequelize/pull/10746/files
- https://github.com/sequelize/sequelize/releases/tag/v5.3.0
Get alerted when CVE-2019-11069 or the next vulnerability affects your stack