What’s Vulnerable › Vulnerabilities
CVE-2019-11070
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-10 · updated 2026-06-17
- Weakness: CWE-19
Description
WebKitGTK and WPE WebKit prior to version 2.24.1 failed to properly apply configured HTTP proxy settings when downloading livestream video (HLS, DASH, or Smooth Streaming), an error resulting in deanonymization. This issue was corrected by changing the way livestreams are downloaded.
Affected products
- Webkit: before 2.24.1 — fixed in 2.24.1
- Wpewebkit Wpe Webkit: before 2.24.1 — fixed in 2.24.1
How to fix
Upgrade to a fixed version: Webkit 2.24.1; Wpewebkit Wpe Webkit 2.24.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00031.html
- http://packetstormsecurity.com/files/152485/WebKitGTK-WPE-WebKit-URI-Spoofing-Code-Execution.html
- http://www.openwall.com/lists/oss-security/2019/04/11/1
- https://bugs.webkit.org/show_bug.cgi?id=193718
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YO5ZBUWOOXMVZPBYLZRDZF6ZQGBYJERQ/
- https://seclists.org/bugtraq/2019/Apr/21
- https://security.gentoo.org/glsa/201909-05
- https://trac.webkit.org/changeset/243197/webkit
- https://usn.ubuntu.com/3948-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00031.html
Get alerted when CVE-2019-11070 or the next vulnerability affects your stack