What’s Vulnerable › Vulnerabilities
CVE-2019-11235
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-22 · updated 2026-06-17
- Weakness: CWE-345
Description
FreeRADIUS before 3.0.19 mishandles the "each participant verifies that the received scalar is within a range, and that the received group element is a valid point on the curve being used" protection mechanism, aka a "Dragonblood" issue, a similar issue to CVE-2019-9498 and CVE-2019-9499.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10, 19.04
- Fedoraproject Fedora: all versions
- freeradius: before 3.0.19 — fixed in 3.0.19
- openSUSE Leap: 15.0
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Eus: 7.6
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: freeradius 3.0.19. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00014.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00032.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00033.html
- https://access.redhat.com/errata/RHSA-2019:1131
- https://access.redhat.com/errata/RHSA-2019:1142
- https://bugzilla.redhat.com/show_bug.cgi?id=1695748
- https://freeradius.org/release_notes/?br=3.0.x&re=3.0.19
- https://freeradius.org/security/
- https://papers.mathyvanhoef.com/dragonblood.pdf
- https://usn.ubuntu.com/3954-1/
- https://www.kb.cert.org/vuls/id/871675/
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00014.html
Get alerted when CVE-2019-11235 or the next vulnerability affects your stack