What’s Vulnerable › Vulnerabilities
CVE-2019-11247: Kubernetes kube-apiserver allows access to custom resources via wrong scope
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-29 · updated 2026-06-17
- Weakness: CWE-20
Description
The Kubernetes kube-apiserver mistakenly allows access to a cluster-scoped custom resource if the request is made as if the resource were namespaced. Authorizations for the resource accessed in this manner are enforced using roles and role bindings within the namespace, meaning that a user with access only to a resource in one namespace could create, view update or delete the cluster-scoped resource (according to their namespace role privileges). Kubernetes affected versions include versions prior to 1.13.9, versions prior to 1.14.5, versions prior to 1.15.2, and versions 1.7, 1.8, 1.9, 1.10, 1.11, 1.12.
Affected products
- Kubernetes: from 1.7.0 through 1.12.10; from 1.13.0 before 1.13.9; from 1.14.0 before 1.14.5; from 1.15.0 before 1.15.2; 1.12.11-beta0 — fixed in 1.13.9, 1.14.5, 1.15.2
- Red Hat OpenShift Container Platform 4.18: 3.9, 3.10, 3.11
How to fix
Upgrade to a fixed version: Kubernetes 1.13.9, 1.14.5, 1.15.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHBA-2019:2816
- https://access.redhat.com/errata/RHBA-2019:2824
- https://access.redhat.com/errata/RHSA-2019:2690
- https://access.redhat.com/errata/RHSA-2019:2769
- https://github.com/kubernetes/kubernetes/issues/80983
- https://groups.google.com/d/msg/kubernetes-security-announce/vUtEcSEY6SM/v2ZZxsmtFQAJ
- https://security.netapp.com/advisory/ntap-20190919-0003/
- https://access.redhat.com/errata/RHBA-2019:2816
- https://access.redhat.com/errata/RHBA-2019:2824
- https://access.redhat.com/errata/RHSA-2019:2690
- https://access.redhat.com/errata/RHSA-2019:2769
- https://github.com/kubernetes/kubernetes/issues/80983
Get alerted when CVE-2019-11247 or the next vulnerability affects your stack