What’s Vulnerable › Vulnerabilities
CVE-2019-11250: Kubernetes client-go logs authorization headers at debug verbosity levels
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-29 · updated 2026-06-17
- Weakness: CWE-532
Description
The Kubernetes client-go library logs request headers at verbosity levels of 7 or higher. This can disclose credentials to unauthorized users via logs or command output. Kubernetes components (such as kube-apiserver) prior to v1.16.0, which make use of basic or bearer token authentication, and run at high verbosity levels, are affected.
Affected products
- Kubernetes: before 1.15.3; 1.15.3, 1.15.4-beta0, 1.16.0-alpha1, 1.16.0-alpha2, 1.16.0-alpha3, 1.16.0-beta1 (+1) — fixed in 1.15.3
- Red Hat OpenShift Container Platform 4.18: 3.11, 4.1
How to fix
Upgrade to a fixed version: Kubernetes 1.15.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2020/10/16/2
- https://access.redhat.com/errata/RHSA-2019:4052
- https://access.redhat.com/errata/RHSA-2019:4087
- https://github.com/kubernetes/kubernetes/issues/81114
- https://security.netapp.com/advisory/ntap-20190919-0003/
- http://www.openwall.com/lists/oss-security/2020/10/16/2
- https://access.redhat.com/errata/RHSA-2019:4052
- https://access.redhat.com/errata/RHSA-2019:4087
- https://github.com/kubernetes/kubernetes/issues/81114
- https://security.netapp.com/advisory/ntap-20190919-0003/
Get alerted when CVE-2019-11250 or the next vulnerability affects your stack