What’s Vulnerable › Vulnerabilities

CVE-2019-11253: Kubernetes API Server JSON/YAML parsing vulnerable to resource exhaustion attack

Description

Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.

Affected products

How to fix

Upgrade to a fixed version: Kubernetes 1.13.12, 1.14.8, 1.15.5, 1.16.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-11253 or the next vulnerability affects your stack