What’s Vulnerable › Vulnerabilities

CVE-2019-11254: Kubernetes API Server denial of service vulnerability from malicious YAML payloads

Description

The Kubernetes API Server component in versions 1.1-1.14, and versions prior to 1.15.10, 1.16.7 and 1.17.3 allows an authorized user who sends malicious YAML payloads to cause the kube-apiserver to consume excessive CPU cycles while parsing YAML.

Affected products

How to fix

Upgrade to a fixed version: Kubernetes 1.15.10, 1.16.7, 1.17.3; Gopkg.In/Yaml.V2 2.2.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-11254 or the next vulnerability affects your stack