What’s Vulnerable › Vulnerabilities
CVE-2019-11272: PlaintextPasswordEncoder authenticates encoded passwords that are null
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-26 · updated 2026-06-17
- Weakness: CWE-287
Description
Spring Security, versions 4.2.x up to 4.2.12, and older unsupported versions support plain text passwords using PlaintextPasswordEncoder. If an application using an affected version of Spring Security is leveraging PlaintextPasswordEncoder and a user has a null encoded password, a malicious user (or attacker) can authenticate using a password of "null".
Affected products
- Debian Linux: 8.0
- Spring Security: before 4.2.13 — fixed in 4.2.13
- Spring Security: from 4.2 before 4.2.13.RELEASE — fixed in 4.2.13.RELEASE
How to fix
Upgrade to a fixed version: Spring Security 4.2.13; Spring Security 4.2.13.RELEASE. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2019/07/msg00008.html
- https://pivotal.io/security/cve-2019-11272
- https://lists.debian.org/debian-lts-announce/2019/07/msg00008.html
- https://pivotal.io/security/cve-2019-11272
Get alerted when CVE-2019-11272 or the next vulnerability affects your stack