What’s Vulnerable › Vulnerabilities
CVE-2019-11277: Volume Services is vulnerable to an LDAP injection attack
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-23 · updated 2026-06-17
- Weakness: CWE-90
Description
Cloud Foundry NFS Volume Service, 1.7.x versions prior to 1.7.11 and 2.x versions prior to 2.3.0, is vulnerable to LDAP injection. A remote authenticated malicious space developer can potentially inject LDAP filters via service instance creation, facilitating the malicious space developer to deny service or perform a dictionary attack.
Affected products
- Cloud Foundry cf-deployment: before 11.1.0 — fixed in 11.1.0
- Cloudfoundry Nfs Volume Release: from 1.7.0 before 1.7.11; from 2.0.0 before 2.3.0 — fixed in 1.7.11, 2.3.0
How to fix
Upgrade to a fixed version: Cloud Foundry cf-deployment 11.1.0; Cloudfoundry Nfs Volume Release 1.7.11, 2.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-11277 or the next vulnerability affects your stack