What’s Vulnerable › Vulnerabilities
CVE-2019-11278: Privilege Escalation via Blind SCIM Injection in UAA
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-26 · updated 2026-06-17
- Weakness: CWE-77
Description
CF UAA versions prior to 74.1.0, allow external input to be directly queried against. A remote malicious user with 'client.write' and 'groups.update' can craft a SCIM query, which leaks information that allows an escalation of privileges, ultimately allowing the malicious user to gain control of UAA scopes they should not have.
Affected products
- Cloudfoundry User Account And Authentication: before 74.1.0 — fixed in 74.1.0
How to fix
Upgrade to a fixed version: Cloudfoundry User Account And Authentication 74.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-11278 or the next vulnerability affects your stack