What’s Vulnerable › Vulnerabilities
CVE-2019-11279: Privilege Escalation via Scope Manipulation in UAA
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-26 · updated 2026-06-17
- Weakness: CWE-77
Description
CF UAA versions prior to 74.1.0 can request scopes for a client that shouldn't be allowed by submitting an array of requested scopes. A remote malicious user can escalate their own privileges to any scope, allowing them to take control of UAA and the resources it controls.
Affected products
- Cloudfoundry Uaa Release: before 74.1.0 — fixed in 74.1.0
How to fix
Upgrade to a fixed version: Cloudfoundry Uaa Release 74.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-11279 or the next vulnerability affects your stack