What’s Vulnerable › Vulnerabilities

CVE-2019-11281: RabbitMQ XSS attack

Description

Pivotal RabbitMQ, versions prior to v3.7.18, and RabbitMQ for PCF, versions 1.15.x prior to 1.15.13, versions 1.16.x prior to 1.16.6, and versions 1.17.x prior to 1.17.3, contain two components, the virtual host limits page, and the federation management UI, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack that would gain access to virtual hosts and policy management information.

Affected products

How to fix

Upgrade to a fixed version: Pivotal RabbitMQ 1.15.13, 1.16.6, 1.17.3, 3.7.18. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-11281 or the next vulnerability affects your stack